There's an ongoing outage in the AWS Cube Cloud

Major incident Cube Cloud Regions aws-us-west-2 aws-ca-central-1 aws-eu-central-1
2021-09-20 23:17 PDT · 5 hours, 25 minutes, 42 seconds

Updates

Resolved

All regions are back online

September 21, 2021 · 04:43 PDT
Issue

details TBD

September 20, 2021 · 23:18 PDT

← Back